WordPress MU 2.8.1のアップグレード

2009 07月12日(日)

ダッシュボードに、「WordPress MU 2.8.1 が利用可能です ! アップデートしてください。」と表示されていたので、自動でアップデートを行ったら、アップデートの途中で下記のエラーメッセージが表示され失敗した模様。

Warning: copy(/xxx/xxxxx/wp-content/upgrade/wordpress-mu-2.8.1/wordpress/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: No such file or directory in /xxx/xxxxx/wp-admin/includes/class-wp-filesystem-direct.php on line 131

アップデートの前に、データベースのバックアップだけは行っているので、強気でもうい一度自動でアップデート行うも、同じエラーメッセージが出る。

アップデートを失敗したかなと、サイトのブログを見たら動いているので、胸をなでおろす。

ダッシュボードには、「WordPress MU 2.8.1 が利用可能です ! アップデートしてください。」とまだ表示されているので、ここは手動でアップデートと思い、手動でアップデートを行った。

手動でアップデートを行った後も、ダッシュボードには、「WordPress MU 2.8.1 が利用可能です ! アップデートしてください。」と表示したまま。

さて、どうなっているのかな?

WordPressMUのForumsにはこんな投稿もある。

Upgrade message still appears after upgrading?

WordPress MU 2.8.1 error?

追記:7月15日

下記参考に、wp-includes/functions.phpwp-includes/wpmu-functions.php を変更する事により、「・・・アップデートしてください。」の表示は消えた。

http://trac.mu.wordpress.org/changeset/1868

関連する投稿

1 コメント

トラックバック / ピンバック

  1. WordPress MU 2.8.1のアップグレードでエラー - まったりなぶろぐ

    […] WordPress MU 2.8.1 の アップデート途中で表示。 WordPress MU 2.8.1のアップグレード […]

Powered by WordPress.